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Basic setup 

    

To perform the most basic of functions, you would require: 

 

HARDWARE: 

• BCore Board 

• A 6V-12V DC power supply 

• FTDI USB Download Key 

 

SOTWARE: 

• BCore IDE 

• CommKey Driver 

• .NET Platform 

 

Note: All required software is available for download here. 

 

Instruction Steps: 

1. Setup the BCore with reference to the connections 

shown in the figure on the left. 

 

2. Connect your Download Key to any USB Port on your 

PC. 

The download port is the JST connector located at the 

outermost edge of the board for all BCore boards. 

Please refer to the BCore Reference Datasheet for 

more details.  

NOTE: Please install the Download Key driver BEFORE 

connecting the Download Key to the PC. If you have 

not already done so, please install the latest version of 

the BCore IDE, you may need to install the .NET 

Platform if your PC does not already have it in the 

system. The driver and software can be obtained from 

our website. 

 

3. Power up the Board. 

4. Launch Bcore IDE.  
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Launching Bcore IDe 

 

Upon launching the BCore IDE (BlazingCore 

requesting the Comm. Number. The

have plugged in your Download Key. 

 

Press OK when you’re done and the port should automatically open if the port number is valid.

indicators on the bottom status bar

Note: You may locate the CommPort Set

 

Creating a new project 

To create a new project, go to File > New Project

 

 

A new project will be automatically created for you, along with the standard structures of a program in the 

editor.  

 

 
SAVING YOUR PROJECT 
Before continuing, lets save this project. This can be done under 

Icon on the toolbar. The Save Dialog should ap

e.g. “My Project” and hit the save button when you are done.

Keyboard Short-Cut: CTRL + S. 

 

 

Bcore Ide 

BlazingCore Integrated Development Environment), a dialog should pop up 

e Comm. Number can be obtained from your Device Manager when you 

Key.  

You can get the port numbers through:   

Control Panel > System > Device Manager > Ports

 

In this case, the port number is COM26. 

when you’re done and the port should automatically open if the port number is valid.

status bar stating “COM26 Open”.  

CommPort Setting Download under: Comm > Comm Setting 

File > New Project. Keyboard Short-Cut: CTRL + N. 

  

A new project will be automatically created for you, along with the standard structures of a program in the 

 

A project consists of your code, which is contained in M

be writing your program in Modules. The Module whic

subroutine “Main” is your Main Module. Every Program MUST have a 

subroutine called Main(), and each subroutine has to have a unique 

name.  

 

TIP: You can rename your modules to whatever you want to call it. This 

can be done under: Project > Rename. 

 

 

 

Before continuing, lets save this project. This can be done under File > Save Project or clicking on the 

The Save Dialog should appear. Type in the project name that you would like to save as, 

e.g. “My Project” and hit the save button when you are done. 

dialog should pop up 

omm. Number can be obtained from your Device Manager when you 

Manager > Ports 

when you’re done and the port should automatically open if the port number is valid. There are 

 

A new project will be automatically created for you, along with the standard structures of a program in the 

A project consists of your code, which is contained in Modules. You will 

be writing your program in Modules. The Module which contains the 

is your Main Module. Every Program MUST have a 

subroutine called Main(), and each subroutine has to have a unique 

to whatever you want to call it. This 

or clicking on the Save 

pear. Type in the project name that you would like to save as, 

    



 

COMPILING YOUR PROJECT 
 

You can now compile your project by selecting 

toolbar. Keyboard Short-Cut: F4.  

 

Compiling the project checks for any syntax errors in your program, you should not encounter any errors here.  

You can tell the number of errors you currently have, from the bottom indication i

see something as follow.   

 

 

 

COMPILING AND DOWNLOADING YOUR 
 
Since there are no errors in our project, let’s download it into the 

Compile And Download or press the

Keyboard Short-Cut: F5. 

 

You may have to wait for a moment for the download process to complete. Your download is successful if 

there are no errors reported.  

 

If you get an error message, such as

 

Check the following: 

 

• Make sure your power supply is on.

• Make sure that the Download Key

• Make sure you have the right Comm Port setting.
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You can now compile your project by selecting Project > Compile or clicking on the Compile Icon on the 

Compiling the project checks for any syntax errors in your program, you should not encounter any errors here.  

You can tell the number of errors you currently have, from the bottom indication in FIDE. For now, you should 

 

COMPILING AND DOWNLOADING YOUR PROJECT 

Since there are no errors in our project, let’s download it into the FI. From the FIDE menu choose:

the icon on the tool bar.  

You may have to wait for a moment for the download process to complete. Your download is successful if 

If you get an error message, such as: “Download Error”   

e sure your power supply is on.  The power indicator on your BCore board should light up.

Key is connected properly to the BCore board and to your PC.

Make sure you have the right Comm Port setting. 

 

Compile Icon on the 

Compiling the project checks for any syntax errors in your program, you should not encounter any errors here.  

n FIDE. For now, you should 

IDE menu choose: Project > 

You may have to wait for a moment for the download process to complete. Your download is successful if 

board should light up. 

board and to your PC. 

    



The Hello World Program 
Congratulations, you have successfully created, compiled and downloaded your first F

Now for more VB coding. 

 

The language you will be using is VB

you work more with BCoreIDE. One of which is tha

when programming on the .NET platform and style

 

Debug.Print is a BCore OS command that send

the Serial Download Port.  In this case it sends “HELLO WORLD” to the PC.  

 

Now Download and Compile your project. 

(Reminder: you can Download and Compile you

 

 

After Compiling and Downloading your Project, 

WORLD” appearing at the debug window.

of your editor.

 

Understanding the Hello World Program
 

A Project consists of one or more modules.  Each Module consists of 

Subroutine.  Every Project must have the Main() subroutine.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Hello World! 

PROJECT

Project Name : Project01

MODULE

Project Name : Module01 Project Name 

Public Sub Main()

Subroutines

Public Sub Foo()

Declaration

Between the Public Sub Main() and the End Sub is where you writ

 

In our Project, we have 1 Module and 1 Subroutine call

The first line ‘Module01 is a commented line which means that the compiler does not execute the line.  A 

commented line is denoted by its highlighted colour (

 

you have successfully created, compiled and downloaded your first FI Project. 

anguage you will be using is VB.NET (Visual Basic); there are a number of differences as you will see when 

. One of which is that the language is streamlined to be similar to that used 

platform and style instead of the conventional VB language.

 

In the BCoreIDE Editor, type the following; 

 Debug.Print “HELLO WORLD” 

 

 

 

Note: It is best to leave your Caps Lock ON.  The Editor will 

automatically format your text as you type. 

 

 

command that sends the message between the quotes back to the PC

.  In this case it sends “HELLO WORLD” to the PC.   

Now Download and Compile your project.  

: you can Download and Compile your project by pressing F5 or clicking the 

After Compiling and Downloading your Project, you should see the message “HELLO 

WORLD” appearing at the debug window. The debug window is located to the right 

of your editor. 

World Program 

A Project consists of one or more modules.  Each Module consists of a declaration and one or more 

Subroutine.  Every Project must have the Main() subroutine. 

 

MODULE

Project Name : Module02

Between the Public Sub Main() and the End Sub is where you write your program. 

and 1 Subroutine called Sub Main().  There are no declarations

The first line ‘Module01 is a commented line which means that the compiler does not execute the line.  A 

ted by its highlighted colour (green). 

I Project.  

there are a number of differences as you will see when 

be similar to that used 

VB language. 

.  The Editor will 

message between the quotes back to the PC through 

icon.) 

you should see the message “HELLO 

The debug window is located to the right 

declaration and one or more 

    

rations in our Project.  

The first line ‘Module01 is a commented line which means that the compiler does not execute the line.  A 



The BLINKY LED Program 
Here’s another simple program. If you have an LED module, you can turn on and turn off the LED by using the 

following OS commands. 

HIGH 
Set logic 1 at the specified pin.  

 

HIGH [ pin no. ] 

 

LOW 
Set logic 0 at the specified pin.  

 

LOW [ pin no. ] 

 

NOTE: I/O pins are tied low to the ground on the hardware therefore explaining the inverse result as opposed 

to the logic statements. 

 

Write the following program and when you’re done, Compile and Download it. 

 

 
 

Replace ‘x’ with the pin number assigned to the IO pins on the BCore Board to which you connected the LED. 

You can obtain these numbers by referring to the BCore Reference Documentation (Hardware) for your 

respective BCore Board. 

 

Hint: You can restart the program by pressing the master reset button on the BCore board. 

 

After downloading the program, you will find that the LED blinks once for 200 msec. 

 

Understanding the Blinky led Program 
The Program starts by sending “HELLO WORLD” to the PC.  Then the LED will be turned on.  The program waits 

for 200 msec (or 0.2 sec) before turning the green LED off. And that’s it! 

 

 

 

  

 

BLINKY LEDs!! 

    



 

Basic structure: Do… Loop 

In the previous program, we will need to type 3 times to blink the green LED 3 times.  Or maybe we can just 

cut and paste the 3 lines.  What do we need for the BCore to instruct the LED to blink indefinitely? 

What we need is to implement is a structure called Do…Loop. 

 

Type in the following program and read the explanation before downloading it. 

 

 

The Do Loop repeats all commands between the Do and the Loop. 

Note the Delay(200) Command After the High Command. This is required before it executes the next 

instruction, which is Low(x), not having a delay would result in the LEDs turning on and off so fast so fast, 

(Remember, the BCore is able to execute instructions at up to 5 Million lines of instructions per second), that 

the human eye will not be able to see the LED Blinking. 

  

 

BLINKY LEDs!! (Cont’d) 

    



 

 

Notes 

    

 2009 AIS Cube. All rights reserved. 

The BlazingCore(BCore) and BCore IDE are either registered trademarks or trademarks of AIS Cube in Singapore and/or 

other countries. All images depicting the Blazingcore or any part of it is copyrighted. 

Microsoft, Windows, Visual Basic and Visual C# are either registered trademarks or trademarks of Microsoft 

Corporation in the United States and/or other countries. 

Adobe and Acrobat are trademarks of Adobe Systems Incorporated. 

 

Latest documentation 

All our documentations are constantly updating to provide accurate and/or new information that we feel 

would help you with developing with our products.  

 

The latest documentation may be obtained from our website: www.aiscube.com 

 

How you can help 

You can help us to improve our documentations by emailing to us or posting a thread in our forum, reporting 

any mistakes/typos or errata that you might spot while reading our documentation. We’d get it clarified the 

next time we update. 

 

Email: TechSupport@aiscube.com 

Forum: http://forum.aiscube.com/index.php 

 


