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System environment 
 

System requirements 

- Windows 98, Windows NT, Windows 2000, Windows XP 

 

Target Device 

- FDA12 

- FIM10 – HV, FIM10 – LV 

- FIM01 

 

Communication 

- COM port 

 

The specification of serial cable 

Target Board Type of Cable 

FDA12 9 pin (F) / 9 pin (M) direct type 

FIM10 9 pin (F) / 9 pin (F) cross type 

FIM01 9 pin (F) / 9 pin (F) cross type 
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1. How to Connect 
 

1.1 About the Evaluation Program 

 

 

 

 

 

[Figure 1] Main window of the Evaluation Program 

 

The evaluation program, “EvTools
TM

” which is shown above, is mainly designed to test and 

evaluate functions of FDA12, FIM10 and FIM01. The initial display is composed of an image 

window for fingerprint (FP) display, information box for system information and a few buttons for 

Target Device 

Information of 

FDA12 / FIM10 / 

FIM01 

Basic 

Operation   

Button 

Status  

Window 

Fingerprint Image 

Display Window  

Pull down 

Menu 

Continuous 

Capture 
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a specific function. And it is possible to set/get hardware configuration like baud rate of serial 

communication (RS232) and manage FP database (DB) in the EvTools
TM

. 

 

 

1.2 Initial Connection 

 

After executing “FIM_EvTools.exe”, you can communicate with the target device.  

 

[Figure 2] The selection of target device 

 

For connection, you should select target device type by selecting ‘File->Select Board -> FDA12 

/ FIM10 / FIM01’ after checking a serial cable and power line are correctly connected. And then 

click ‘CONNECT’ button. If the connection is successfully made, a success message shown in 
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[Figure 3] pops up. Otherwise a failure message pops up. The Initial baud of serial 

communication is set to 9,600 bps by default. 

  

[Figure 3] The messages window for establishing the connection of serial communication 

 

 

1.3 Serial Communication Set-Up 

 

In the EvTools
TM

, you can change baud rate you want. Firstly, select ‘File->Serial Comm’ to 

display the configuration window shown in [Figure 4]. Then change baud rate to the new value 

and click ‘SET BAUD RATE’ button. The default baud rate of device is 9,600 bps. 

 

[Figure 4] Serial communication configuration window 

 

If all procedures are successfully done, the message window shown in [Figure 5] is displayed. 

 

[Figure 5] Success message window for changing baud rate 

 

For a communication with a new baud rate, try to connect again by clicking the ‘CONNECT’ 

button. 

In FDA12 and FIM10, both device and EvTools
TM 

‘s baud rate are changed by this function. But 
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in FIM01, Only EvTools
TM 

‘s baud rate is changed. The baud rate of FIM01 can be changed in 

the system configuration window. Refer to Appendix A. 
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2. Operation of Basic Functions 
 

2.1 Master Mode 

 

 

[Figure 6] Main window after connection 

 

The Main window configuration is different between device types. 

After connecting, most of all buttons get activated as shown in [Figure 6]. But several buttons 

like ‘ENROLL’ still are not enabled by the reason that these functions should be done by 

masters. 

The device doesn’t have any registered user initially. So, first of all, you should register the first 

master FP after changing to master mode by clicking the ‘ENTER MASTER MODE’ button. 
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In the master mode, it is possible to add/delete user, convert user privilege (normal/master) and 

create/delete password for user and device. In FIM01, it is possible to change user FP and 

password, too. 

If masters or device password were registered in device, the device asks master authentication 

with FP, password or device password to change into master mode. It will be explained later at 

section 3.2.4 and 3.5. 

 

[Figure 7] Main window in master mode 

 

2.2 Enrollment 

 

This paragraph explains the procedure of enrolling a new user. After clicking the ‘ENROLL’ 

button in master mode, the request window for FP ID and password shown in [Figure 8] is 
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displayed for each device. 

  

FDA12                    FIM10 & FIM01 

[Figure 8] Request window for fingerprint ID and password 

 

The FP ID is possible up to 9 digits in FDA12 and FIM10, and is possible up to 10 digits in 

FIM01. Optionally the password is possible up to 15 digits and the selection of master privilege 

is possible in FIM10 and FIM01. 

 

 

[Figure 9] Warning message window for existence of the same ID 

 

The new ID should be unique and different from all enrolled IDs. If the same ID exists, warning 

message window shown in [Figure 9] is displayed and the enrollment procedure gets terminated. 

If new ID is enrolled successfully, success message is displayed as shown in [Figure 10] and 

then goes to the next step. 
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[Figure 10] Message for FP registration 

 

After the first FP registration is done successfully, the below message window, [Figure 11], 

shows up. At this moment, take your finger off sensor and then put the same finger on the 

sensor again for the second FP registration. 

 

[Figure 11] Message window for the success of the first FP registration 
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If the second FP is identical to the first FP, enrollment procedure is done successfully and the 

message window, [Figure 12], shows up. However, if the enrollment is failed, the message 

window, [Figure 13], shows up. 

 

[Figure 12] Success message window of enrollment 

 

 

[Figure 13] Failure message window of enrollment 

 

2.3 Deletion 

 

This paragraph explains the procedure of deleting a user record. 

After clicking the ‘DELETE’ button in master mode, the window what requests fingerprint ID 

shows up. Type ID to be deleted and then clicks ‘OK’. After the procedure of deletion is done 

successfully, the message window, [Figure 14], shows up. On the other hand, if there exists the 

same ID, the message window such as ‘Invalid ID’ shows up. 

 

 [Figure 14] Success message for deletion 

 

2.4 Change 

 

This paragraph explains the procedure of changing user record. 

After clicking the ‘CHANGE’ button in master mode, the window to select change mode shown 
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in [Figure 15] is displayed. 

 

[Figure 15] The window to select change mode 

 

* User record structure refers to developer’s guide. 

* This function is only supported in FIM01 

 

2.4.1. Change Master Privilege & Save 

After selecting the ‘Change Master Privilege & Save’ and clicking the ‘OK’ button, the request 

window for FP ID and privilege shown in [Figure 16] is displayed. Type ID to be changed 

privilege and a new privilege, and then click the ‘OK’ button. 

 

[Figure 16] Request window for FP ID and privilege 

 

The new privilege should be different from enrolled privilege. If the new privilege is the same as 

old it, warning message window shown in [Figure 18] is displayed and the change procedure 

gets terminated. If the privilege is changed successfully, message window shown in [Figure 17] 

pops up. 

 

[Figure 17] Success message window for changing privilege 
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[Figure 18] Warning message window for wrong ID 

 

2.4.2. Change Password & Save 

After selecting the ‘Change Password & Save’ and clicking the ‘OK’ button, the request window 

for FP ID and password shown in [Figure 19] is displayed. Type ID to be changed password and 

a new password, and then click the ‘OK’ button. If the password is changed successfully, 

message window shown in [Figure 20] pops up. 

 

[Figure 19] Request window for fingerprint ID and password 

 

 

[Figure 20] Success message window for changing password 

 

2.4.3. Change Minutiae from Host 

After selecting the ‘Change Minutiae from Host’ and clicking the ‘OK’ button, the request window 

for FP ID shown in [Figure 19] is displayed. Type ID to be changed minutiae, and click the ‘OK’ 

button, and then dialog window for opening minutiae file pops up like the following [Figure 21]. 

First of all, you should choose minutiae file yon want to change, and the dialog window pops up 

again, and then you choose other minutiae file that was extracted from same FP. 

If both first minutiae and second minutiae are extracted from same fingerprint, success 
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message window shown in [Figure 21] is displayed. If both first minutiae and second minutiae 

are extracted from other fingerprint or first minutiae and second minutiae are identical, warning 

message box shown in [Figure 13] is displayed. 

 

 

[Figure 21] Dialog window for opening fingerprint minutiae file 

 

 

[Figure 22] Success message window for changing fingerprint minutiae 

 

2.4.4. Change Minutiae from Sensor 

After selecting the ‘Change Minutiae from Sensor’ and clicking the ‘OK’ button, the request 

window for FP ID shown in [Figure 8] is displayed. Next procedure is the same as enrollment in 

FDA12. 

 

 

2.5 1:1 Matching (Verification) 

 

This paragraph explains the procedure of verification using FP ID. 

The ‘VERIFY’ button is used to compare minutiae extracted from the captured FP with enrolled 

minutiae that have the same ID. After clicking the ‘VERIFY’ button, the request window for FP ID 
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pops up. Types ID to be matched and then place finger on the sensor. 

If the 1:1 matching, called ‘Verification’, is done successfully, the success message window, 

[Figure 23], pops up. Otherwise the failure message window, [Figure 24], pops up. 

 

[Figure 23] Success message for the 1:1 matching 

 

 

[Figure 24] Failure message for the 1:1 matching 

 

If the wrong ID is incidentally entered, click the ‘CANCEL’ button to terminate the procedure of 

verification. In this case, the cancel message window, [Figure 25], pops up. 

.  

[Figure 25] Cancel message for the 1:1 matching 

 

 

2.6 1:N Matching (Identification) 

 

This paragraph explains the procedure of identification without using FP ID. 

The ‘IDENTIFY’ button is used to compare minutiae extracted from the captured FP with all FP 

minutiae in DB of the device. After clicking the ‘IDENTIFY’ button, place finger on the sensor. 

If the identical FP is founded through the 1:N matching, called ‘Identification’, the success 

message window, [Figure 26], pops up. On the other hand, if the identical FP is not founded, the 

failure message window, [Figure 27], pops up. 
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[Figure 26] Success message for the 1:N matching 

 

 

[Figure 27] Failure message for the 1:N matching 

 

Also, identification procedure can be canceled by clicking the ‘CANCEL’ button, and then the 

cancel message window, [Figure 28], pops up. 

 

[Figure 28] Failure message for 1:N recognition 

 

2.7 Instant Matching 

 

The Instant Matching is used to compare the minutiae stored outside the device with minutiae 

extracted from the captured FP. 

After clicking the ‘INSTANT MATCHING’ button, dialog window for opening minutiae file as 

shown in [Figure 21] pops up. Choose minutiae file you want to match, then place finger on the 

sensor. 

 

2.8 Instant Verify 

 

The Instant Verify is used to compare the minutiae stored outside the device with the minutiae 

stored inside the device. 
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After clicking the ‘INSTANT VERIFY’ button, request window for FP ID is displayed, and then 

type ID to be compared. Subsequently dialog window for opening minutiae file pops up, and 

then you choose it. Next procedure is same as verification. 

 

* This function is only supported in FIM01 

 

2.9 Instant Identify 

 

The Instant Identify is used to compare the minutiae stored outside the device with the minutiae 

in DB of the device. 

After clicking the ‘INSTANT IDENTIFY’ button, dialog window for opening minutiae file pops up, 

and then you choose it. Next procedure is same as identification. 

 

* This function is only supported in FIM01 

 

2.10 Get Minutiae 

 

The Get Minutiae is used to save minutiae data as a file from the captured FP. 

After clicking the ‘GET MINUTIAE’ button, place finger on the sensor. The dialog window for 

saving minutiae as a file, [Figure 29], pops up. Type the name of the minutiae file to save. 

This function is available at the FDA12 firmware V1.1 or later, FIM10 series, and FIM01. 

 

[Figure 29] Dialog window for saving minutiae as a file 
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2.11 Fingerprint Capture 

 

2.11.1. Capture 

The image captured through the sensor can be seen by this function. After clicking the 

‘CAPTURE’ button, place FP on the sensor. 

The captured FP is displayed at FP image display window inside main window. If you want to 

save captured FP, select ‘File->Save Image As’. Then the dialog window, [Figure 30], pops up. 

Type the name of the image file to save. EvTools currently supports only raw image data. 

The stored FP image can be seen again at FP image display window by selecting ‘File->Open 

Image’. 

 

[Figure 30] Dialog window for saving FP image as a file 

 

2.11.2. Continuous Capture 

This function is used to continuously capture FP through the sensor and display it. After 

checking the ‘Continuous Capture’ box and clicking the ‘START’ button, place FP on the sensor. 

The following [Figure 31] shows the main window doing continuous capture. 
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[Figure 31] Continuous capture 

 

During continuous capture, ‘Success’ value indicates how many images are captured 

successfully. And ‘Fail’ indicates how many errors occur. 

Click the ‘STOP’ button to stop capture. 
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3. Operation of Additional Functions 

 

3.1 System Configuration 

 

You can change the device configuration such as image sensor, security level, capture, latent, 

relay, wiegand, and log option in master mode. 

 

  

FDA12 & FIM10                               FIM01 

[Figure 32] System configuration window 

 

In master mode, select View->System Information’ menu. The sub window shown in [Figure 

32] is displayed. After changing each parameter value, click each ‘SET...’ button to make 

changed parameter effective. You can see current parameter values with ‘GET SYSTEM 

INFORMATION’ or ‘GET SYSINFO’ button. 

‘SAVE SYSINFO’ button is only included in system configuration window for FIM01. This button 

is used to save current system configuration of RAM in flash memory. 

FIM01 need this function because of difference in option setup method. In FDA12 or FIM10, 

‘Set’ functions make change parameter in not only RAM but also flash memory. But ‘Set’ 

functions make change parameter only in RAM in FIM01. Consequently, FIM01 is reset then 

changed information is disappeared. So, this button is needed. 

 

* System option is different according to devices (FDA12, FIM10-LV, FIM10-HV, FIM01 etc). 
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3.2 Database Manager 

 

The manipulation of DB is possible through DB Manager window in master mode. 

  

FDA12 & FIM10                               FIM01 

[Figure 33] Database Manager Window 

 

3.2.1. ‘GET FINGERPRINT LIST’ 

All enrolled user IDs and master IDs are displayed like [Figure 34]. The one column is user ID 

and the other column is authority field for a master indication. Normal user ID doesn’t have any 

mark in authority field. By clicking ‘GET FINGERPIRNT LIST’, user lists are displayed. 

 

  

FDA12 & FIM10                                FIM01 

[Figure 34] The DB manager window after getting fingerprint lists 

 

3.2.2. ‘DELETE RECORD’ 

In FDA12 or FIM10, a user can be deleted by clicking ‘DELETE RECORD’ button after selecting 

an ID to be deleted. 
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In FIM01, users can be deleted by clicking ‘DELETE RECORD’ button after checking check 

boxes of ID to be deleted. 

 

3.2.3 ‘DELETE ALL RECORD’ 

All DB are deleted by clicking the ‘DELETE ALL RECORD’ button. 

 

3.2.4. ‘SET MASTER’ 

Normal user can be changed to master by clicking ‘SET MASTER’ button after selecting an ID 

to be master. In FDA12, only 5 master IDs are supported 

 

3.2.5. ‘RESET MASTER’ 

Master can be changed to normal user by clicking ‘RESET MASTER’ button after selecting an 

ID to be normal user.  

 

3.2.6 ‘DELETE ALL USER’ 

All normal user are deleted by clicking ‘DELETE ALL USER’ 

 

3.2.7 ‘DELETE ALL MASTER’ 

All master are deleted by clicking ‘DELETE ALL MASTER’ 

 

3.2.8 ‘DOWNLOAD’ 

This function is used to get user record composed of registered user ID, password, encrypted 

fingerprint minutiae, privilege, and registered time from FIM01 and save it as a file. 

If you want to get several user records of DB of FIM01, you check ‘check box’ of ID to be 

downloaded. And click the ‘DOWNLOAD’ button then window shown in [Figure 35] pops up. 

 

 

[Figure 35] Window to select method for download 

 

If you select ‘To get checked records’ and then click ‘OK’, you are able to get user records 
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checked and save it as a file. 

If you select ‘To get full records’ and then click ‘OK’ button in the window, all user records 

registered are downloaded as files. Each file name is same as user ID. 

 

* The structure of DB is described in “NITGEN_CommProtocol” document. 

* This function is only supported in FIM01 

 

3.2.9 ‘OPEN’ 

This function is used to update user records extracted through ‘DOWNLOAD’ function and 

display its information in EvTools. Click the ‘OPEN’ button and then dialog window like [Figure 

37] is displayed in host tab window of database manager as shown in [Figure 36]. 

 

 

[Figure 36] Host tab window of database manager 
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[Figure 37] Dialog window for opening user record 

 

Choose user record files you want to update, and user records are updated, and then the 

update information is displayed as shown in [Figure 38]. 

 

[Figure 38] Window after updating user data 

 

* This function is only supported in FIM01 
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3.2.10 ‘UPLOAD’ 

This function is used to add user records are updated in EvTools
TM

 to FIM01.  

After checking check box of ID for uploading to FIM01, click this button, and then user records 

are added to FIM01 within affordable limit.  

 

 

[Figure 39] Success message for uploading data 

 

* This function is only supported in FIM01 

 

3.2.11 ‘CLEAR’ 

This function is used to delete data of user records updated in EvTools EvTools
TM

. Click this 

button, then all data updated are deleted and list box of host tab is initialized. 

  

* This function is only supported in FIM01 

 

 

3.3 Saving Log Data 

 

This paragraph explains how to save log date as a log file. Prior to saving log data, it should be 

master mode and ‘Log Enable’ of system configuration should be chosen. 
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[Figure 40] The window to save log data 

 

* Log structure is different according to devices (FDA12, FIM10-LV, FIM10-HV, FIM01 etc). 

 

3.3.1 ‘READ & SAVE LOG DATA’ 

Firstly, select ‘View->Log Data’ and then the log data window, [Figure 40], pops up. Click the 

‘READ & SAVE LOG DATA’ button and then click ‘OK’ button in the window [Figure 41]. Input file 

name in the dialog window shown in [Figure 29]. 

 

[Figure 41] Message window to confirm saving log data 

 

3.3.2 ‘DELETE ALL LOG DATA’ 

This function is used to delete all log data in FIM01. After clicking the ‘DELETE ALL LOG DATA’ 

button, Click ‘OK’ button in the message window shown in [Figure 42]. 

 

 

[Figure 42] Message window to confirm deleting all log data 
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* This function is only supported in FIM01 

 

 

3.4 User Data 

 

FDA12, FIM10, and FIM01 have pre-allocated non-volatile memory for user application specific 

purpose. It is possible to write/read application specific data at this memory. It’s so called user 

data. You can write one byte by one byte and read several bytes at one time. 

 

[Figure 43] User data window 

 

* User data size is different according to devices (FDA12, FIM10-LV, FIM10-HV, FIM01 etc). 

 

 

3.5 Device Password 

 

The device (FDA12 / FIM10 / FIM01) supports device password that can be used for master 

authentication without master FP or password. Device password should be created only in 

master mode. 

To create a device password, select ‘Tools->Device Password’ and then the related window, 

[Figure 44] pops up. 
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[Figure 44] Device password window 

 

Type the new password up to 15 digits and then click ‘SET PASSWORD’ button to complete 

creation. On the other hand, if you want to delete a master password, click the ‘DELETE 

PASSWORD’ button. 

 

 

3.6 Set Time 

 

This function is used to read date and time from FIM01 or write date and time to FIM01. After 

setting RTC in power-on, RTC value can be increased. 

 

[Figure 45] Initial window for date and time 

 

* This function is only supported in FIM01 

 

3.6.1 ‘Get Time’ 

This is used to read date and time from FIM01. After click this button, date and time set up in 

FIM01 displayed as shown in [Figure 46]. 
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[Figure 46] Window after clicking ‘Get Time’ 

3.6.2 ‘Set Time’ 

Two procedures are used for set up date and time in FIM01. One is to use date and time set up 

in PC installed EvTools
TM

. Only click the ‘Set Time’ button without check ‘I’ll type in the date & 

time’. The other procedure is to input date and time directly. Check ‘I’ll type in the date & time’, 

and then edit box is displayed as shown in [Figure 47]. After typing date and time for set up in 

FIM01, click the ‘Set Time’ button. 

 

[Figure 47] Widow for inputting date and time 

 

 

3.7 I/O Control 

 

This function is used to turn on/off sensor LED of FIM01 or control relay port. Select the menu 

‘Tools->I/O Control’, and then control window, [Figure 48], pops up. After selecting control item 

(Sensor LED or Relay), proceed test wanted. 
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[Figure 48] I/O control window 

 

* This function is only supported in FIM01 

 

 

3.8 Check Low Voltage 

 

This function is used to check if power level is under low voltage level (DC2.1V) or not. Select 

the menu ‘Tools->Check Low Voltage’. When power is insufficient, change batteries. 

 

 

[Figure 49] Message window indicating sufficient power 

 

* This function is only supported in FDA12 

 

 

3.9 Battery Life Test 

 

This function is used to check how many times recognition process can be done under battery 

operation. Supply power to FDA12 with battery and then select ‘Tools->Q/A Test->Battery Life 

Test’. The battery life test window, [Figure 50], pops up and then test starts automatically 
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[Figure 50] The window of battery life test 

 

‘Count (High Voltage)’ indicates iteration number of recognition until battery is ‘Low voltage’ and 

‘Count (Low Voltage)’ indicates iteration number after battery is ‘Low voltage’. Sum of two 

counts becomes usable total count. 

 

* This function is only supported in FDA12 

 

 

 

 

3.10 Packet Trace 

 

This function is used to observe transmitted packets between device (FDA12 / FIM10 / FIM01) 

and EvTools. Select ‘View->Packet Trace’ and then packet trace window, [Figure 51], shows 

up. 

 

[Figure 51] Initial packet trace window 

 

The packet trace window displays received/transmitted packets according to every command 

and acknowledge. 
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[Figure 52] Packet trace window to display packets 

 

 

3.11 Power On/Off 

 

By using a power down function, FDA12 can be powered off. Click the ‘Power Off’ button and 

then EvTools powers off FDA12 via RTS signal line of RS232. 

The appearance of this button is changed according to power status of FDA12. When FDA12 is 

powered on, the appearance of the button is ‘Power Off’. When powered off, the appearance of 

the button is changed to ‘Power On’. 

 

* This function is only supported in FDA12 

 

3.12 Upgrade Firmware 

 

Programs stored in the flash memory of device can be quickly and easily upgraded using this 

function. From windows menu bar, select ‘Tools->Upgrade Firmware’, and then dialog window 

for opening firmware file pops up. Select a firmware file for upgrade, and then the upgrade is 

proceeding with processing bar window [Figure 53]. Firmware file format of FDA12 is Intel hex 

(*.hex), and firmware file format of FIM10 and FIM01 is binary (*.bin).  

 

[Figure 53] Processing bar window 

 



 

NITGEN _______________________________________________________ Products -  37 
EvTools User Manual 

NITGEN EvTools      

When firmware upgrading completes, success message window, [Figure 54], pops up. 

 

[Figure 54] Success message window for upgrading firmware 
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Appendix A. Serial Communication Set Up in FIM01 
 

In this chapter, how to change baud rate of FIM01 and EvTools
TM is explained. 

 

1. The Change of Baud-rate of FIM01 

 

In master mode, select ‘View->System Information’ menu to display ‘system configuration 

window’. Then change baud rate of channel you want to the new value and click ‘SET’ button. If 

all procedures are successfully done, the message window shown in [Figure 55] is displayed. 

 

[Figure 55] Success message window for changing baud rate of FIM01 

 

‘GET SYSINFO’ and ‘SAVE SYSINFO’ button are inactivated. 

 

[Figure 56] System configuration window after changing baud rate of FIM01 

 

In this status, only the baud rate of FIM01 is changed. So, serial communication is impossible 
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between FIM01 and EvTools
TM

. Close system configuration window. 

 

 

2. 2. 2. 2. The Change of Baud-rate of EvToolsTM    

 

Select ‘File->Serial Comm’ to display the serial communication configuration window, then 

change baud rate as the same as it of FIM01. 

 

 

3. Reconnection 

 

If the baud rate of EvTools
TM 

is changed successfully, try to connect again by clicking the 

‘CONNECT’ button in main window. If the baud rate of EvTools
TM 

and FIM01 is different, 

EvTools
TM 

try to connect FIM01 by changing it automatically.  
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Appendix B. Support Information 
 

 

 

    

NITGEN Co., Ltd. 

Sanhak Foundation Bldg. 5F, 1337-31,  
Seocho-dong, Seocho-gu, Seoul, Korea 

 

Tel: +82-2-3415-1800 

Fax: +82-2-3415-1801 

E-mail.  Customer@nigten.com 
        

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

    

    

    

    

    

    

    

    

        


