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Basic setup 

    

To perform the most basic of functions, you would require: 

 

HARDWARE: 

• BCore Microcontroller Board (Rev.A to Rev.D) 

• A 6V-9V DC power supply 

• FTDI USB Download Key 

 

SOTWARE: 

• BCore IDE 

• CommKey Driver 

• .NET Platform 

 

Note: All required software is available for download from 

www.aiscube.com . 

 

Instruction Steps: 

1. Setup the BCore with reference to the connections 

shown in the figure on the left. 

 

2. Connect your Download Key to any USB Port on your 

PC. 

The download port is the JST connector located at the 

outermost edge of the board for all BCore boards. 

Please refer to the BCore User Manual for more 

details.  

NOTE: Please install the Download Key driver BEFORE 

connecting the Download Key to the PC. If you have 

not already done so, please install the latest version of 

the BCore IDE, you may need to install the .NET 

Platform if your PC does not already have it in the 

system (Not required for Windows® Vista onwards). 

The driver and software can be obtained from our 

website. 

 

3. Power up the Board. 

4. Launch BCore IDE.  

 



 

 
Launching 
 

Upon launching 

requesting the Comm. Number. The Comm. Number can be obtained from your Device Manager when you 

have plugged in your Download Key. 

 

Press OK 

indicators on the bottom status bar stating “COM26 Open”

Note: You may locate the Co

 

Creating a new project
To create a new project, go to 

 

 

A new project will be automatically created for you, along with the standard structures of a program in the 

editor.  

 

 

SAVING YOUR PROJECT
Before continuing, lets save this project. This can be done under 

Icon on the toolbar. The Save Dialog should appear. Type in the 

e.g. “My Project” and hit the save button when you are done.

Keyboard Short

BCORE

Launching BCore IDe

Upon launching BCORE IDE

requesting the Comm. Number. The Comm. Number can be obtained from your Device Manager when you 

have plugged in your Download Key. 

OK when you’re done and the port should automatically open if the port number is valid. There are 

indicators on the bottom status bar stating “COM26 Open”

: You may locate the Co

Creating a new project
To create a new project, go to 

A new project will be automatically created for you, along with the standard structures of a program in the 

SAVING YOUR PROJECT
Before continuing, lets save this project. This can be done under 

Icon on the toolbar. The Save Dialog should appear. Type in the 

e.g. “My Project” and hit the save button when you are done.

Keyboard Short-Cut: CTRL + S

BCORE Ide 

BCore 

IDe 

BCORE IDE (BlazingCore 

requesting the Comm. Number. The Comm. Number can be obtained from your Device Manager when you 

have plugged in your Download Key. 

when you’re done and the port should automatically open if the port number is valid. There are 

indicators on the bottom status bar stating “COM26 Open”

: You may locate the CommPort Setting under: 

Creating a new project 

To create a new project, go to File > New Project

A new project will be automatically created for you, along with the standard structures of a program in the 

SAVING YOUR PROJECT 
Before continuing, lets save this project. This can be done under 

Icon on the toolbar. The Save Dialog should appear. Type in the 

e.g. “My Project” and hit the save button when you are done.

CTRL + S. 

BCore Getting started rev.b

BlazingCore Integrated Development Environment

requesting the Comm. Number. The Comm. Number can be obtained from your Device Manager when you 

have plugged in your Download Key.  

You can get the port numbers through:  

Control Panel > System > Device

 

Look for 

when you’re done and the port should automatically open if the port number is valid. There are 

indicators on the bottom status bar stating “COM26 Open”

mmPort Setting under: 

File > New Project

A new project will be automatically created for you, along with the standard structures of a program in the 

 

A project consists of your code, which is contained in Modules. You will 

be writing your program in Modules. The Module whic

subroutine “Main”

subroutine called Main(), and each subroutine has to have a unique 

name.  

 

There should only be one Main Subroutine for every Project.

 

TIP: You can rename your modules to whatever you wan

can be done under:

 

 

Before continuing, lets save this project. This can be done under 

Icon on the toolbar. The Save Dialog should appear. Type in the 

e.g. “My Project” and hit the save button when you are done.
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tegrated Development Environment

requesting the Comm. Number. The Comm. Number can be obtained from your Device Manager when you 

You can get the port numbers through:  

Control Panel > System > Device

Look for USB Serial Port

when you’re done and the port should automatically open if the port number is valid. There are 

indicators on the bottom status bar stating “COM26 Open”.  

mmPort Setting under: Comm > Comm Setting

File > New Project. Keyboard Short

  

A new project will be automatically created for you, along with the standard structures of a program in the 

A project consists of your code, which is contained in Modules. You will 

be writing your program in Modules. The Module whic

subroutine “Main” is your Main Module. Every Program MUST have a 

subroutine called Main(), and each subroutine has to have a unique 

There should only be one Main Subroutine for every Project.

You can rename your modules to whatever you wan

can be done under: Project > Rename

Before continuing, lets save this project. This can be done under 

Icon on the toolbar. The Save Dialog should appear. Type in the 

e.g. “My Project” and hit the save button when you are done. 
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tegrated Development Environment

requesting the Comm. Number. The Comm. Number can be obtained from your Device Manager when you 

You can get the port numbers through:  

Control Panel > System > Device

USB Serial Port. In this case, the port number is COM26.

when you’re done and the port should automatically open if the port number is valid. There are 

Comm > Comm Setting

. Keyboard Short-Cut: CTRL + N.

A new project will be automatically created for you, along with the standard structures of a program in the 

A project consists of your code, which is contained in Modules. You will 

be writing your program in Modules. The Module whic

is your Main Module. Every Program MUST have a 

subroutine called Main(), and each subroutine has to have a unique 

There should only be one Main Subroutine for every Project.

You can rename your modules to whatever you wan

Project > Rename

Before continuing, lets save this project. This can be done under File > Save Project

Icon on the toolbar. The Save Dialog should appear. Type in the project name that you would like to save as, 

 

Release 

tegrated Development Environment), a dialog should pop up 

requesting the Comm. Number. The Comm. Number can be obtained from your Device Manager when you 

You can get the port numbers through:   

Control Panel > System > Device Manager > Ports

In this case, the port number is COM26.

when you’re done and the port should automatically open if the port number is valid. There are 

Comm > Comm Setting 

CTRL + N. 

A new project will be automatically created for you, along with the standard structures of a program in the 

A project consists of your code, which is contained in Modules. You will 

be writing your program in Modules. The Module whic

is your Main Module. Every Program MUST have a 

subroutine called Main(), and each subroutine has to have a unique 

There should only be one Main Subroutine for every Project.

You can rename your modules to whatever you wan

Project > Rename. 

File > Save Project or clicking on the 

project name that you would like to save as, 

), a dialog should pop up 

requesting the Comm. Number. The Comm. Number can be obtained from your Device Manager when you 

Manager > Ports 

In this case, the port number is COM26.

when you’re done and the port should automatically open if the port number is valid. There are 

 

A new project will be automatically created for you, along with the standard structures of a program in the 

A project consists of your code, which is contained in Modules. You will 

be writing your program in Modules. The Module which contains t

is your Main Module. Every Program MUST have a 

subroutine called Main(), and each subroutine has to have a unique 

There should only be one Main Subroutine for every Project. 

You can rename your modules to whatever you want to call it. This 

or clicking on the 

project name that you would like to save as, 

), a dialog should pop up 

requesting the Comm. Number. The Comm. Number can be obtained from your Device Manager when you 

In this case, the port number is COM26. 

when you’re done and the port should automatically open if the port number is valid. There are 

A new project will be automatically created for you, along with the standard structures of a program in the 

A project consists of your code, which is contained in Modules. You will 

h contains the 

is your Main Module. Every Program MUST have a 

subroutine called Main(), and each subroutine has to have a unique 

t to call it. This 

Save 

project name that you would like to save as, 

    



 

 

 

COMPILING YOUR PROJECT
 

You can now compile your project by selecting 

toolbar. Keyboard Short

 

Compiling the project checks for any syntax errors in your program, you should not encounter any errors here.  

You can tell the number of errors you currently have,

should see something as follow.  

 

 

 

COMPILING AND DOWNLOADING YOUR PROJECT
 
Since there are no errors in our projec

Project > Compile And Download 

Keyboard Short

 

You may have to wait for a moment for the download process to complete. Your download is successful if 

there are no errors reported. 

 

If you get an error message, such as: “

 

Check the follo

 

• Make sure your power supply is on.  The power indicator on your 

• Make sure that the 

• Make sure you have the right Comm Port setting.

 

Important!

By default, programs downloaded are stored in the Core’s SRAM. This memory is volatile, meaning that if you 

power off the board and power it up again, your program will be gone. 

 

Once you are ready and you have finalized your program, you may save the program in

DataFlash chip. On power up, the Core will take the program from the DataFlash chip, transfer it into its 

internal SRAM and run your program. 

 

To save your program into the DataFlash Chip, you need to perform the following 2 steps.

1. 

2. 

 

 

BCORE 

COMPILING YOUR PROJECT

You can now compile your project by selecting 

toolbar. Keyboard Short

Compiling the project checks for any syntax errors in your program, you should not encounter any errors here.  

You can tell the number of errors you currently have,

should see something as follow.  

COMPILING AND DOWNLOADING YOUR PROJECT

Since there are no errors in our projec

Project > Compile And Download 

Keyboard Short-Cut: F5

You may have to wait for a moment for the download process to complete. Your download is successful if 

there are no errors reported. 

If you get an error message, such as: “

Check the following: 

Make sure your power supply is on.  The power indicator on your 

Make sure that the 

Make sure you have the right Comm Port setting.

Important! 

ult, programs downloaded are stored in the Core’s SRAM. This memory is volatile, meaning that if you 

power off the board and power it up again, your program will be gone. 

Once you are ready and you have finalized your program, you may save the program in

DataFlash chip. On power up, the Core will take the program from the DataFlash chip, transfer it into its 

internal SRAM and run your program. 

To save your program into the DataFlash Chip, you need to perform the following 2 steps.

 Project > Compile And Download

 Project > Save Code Mem to Ext OS Mem

BCORE Ide 

BCore 

COMPILING YOUR PROJECT 

You can now compile your project by selecting 

toolbar. Keyboard Short-Cut: F4.  

Compiling the project checks for any syntax errors in your program, you should not encounter any errors here.  

You can tell the number of errors you currently have,

should see something as follow.   

COMPILING AND DOWNLOADING YOUR PROJECT

Since there are no errors in our projec

Project > Compile And Download or press the 

F5. 

You may have to wait for a moment for the download process to complete. Your download is successful if 

there are no errors reported.  

If you get an error message, such as: “

Make sure your power supply is on.  The power indicator on your 

Make sure that the Download Key is connected properly to the 

Make sure you have the right Comm Port setting.

ult, programs downloaded are stored in the Core’s SRAM. This memory is volatile, meaning that if you 

power off the board and power it up again, your program will be gone. 

Once you are ready and you have finalized your program, you may save the program in

DataFlash chip. On power up, the Core will take the program from the DataFlash chip, transfer it into its 

internal SRAM and run your program. 

To save your program into the DataFlash Chip, you need to perform the following 2 steps.

> Compile And Download

Project > Save Code Mem to Ext OS Mem
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You can now compile your project by selecting Project > Compile

Compiling the project checks for any syntax errors in your program, you should not encounter any errors here.  

You can tell the number of errors you currently have,

COMPILING AND DOWNLOADING YOUR PROJECT 

Since there are no errors in our project, let’s download it into the BCore

or press the 

You may have to wait for a moment for the download process to complete. Your download is successful if 

If you get an error message, such as: “Download Error

Make sure your power supply is on.  The power indicator on your 

Key is connected properly to the 

Make sure you have the right Comm Port setting.

ult, programs downloaded are stored in the Core’s SRAM. This memory is volatile, meaning that if you 

power off the board and power it up again, your program will be gone. 

Once you are ready and you have finalized your program, you may save the program in

DataFlash chip. On power up, the Core will take the program from the DataFlash chip, transfer it into its 

internal SRAM and run your program.  

To save your program into the DataFlash Chip, you need to perform the following 2 steps.

> Compile And Download 

Project > Save Code Mem to Ext OS Mem
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Project > Compile

Compiling the project checks for any syntax errors in your program, you should not encounter any errors here.  

You can tell the number of errors you currently have, from the bottom indication in Bco

 

 

t, let’s download it into the BCore

icon on the tool bar. 

You may have to wait for a moment for the download process to complete. Your download is successful if 

Download Error”   

Make sure your power supply is on.  The power indicator on your 

Key is connected properly to the 

Make sure you have the right Comm Port setting. 

ult, programs downloaded are stored in the Core’s SRAM. This memory is volatile, meaning that if you 

power off the board and power it up again, your program will be gone. 

Once you are ready and you have finalized your program, you may save the program in

DataFlash chip. On power up, the Core will take the program from the DataFlash chip, transfer it into its 

To save your program into the DataFlash Chip, you need to perform the following 2 steps.

Project > Save Code Mem to Ext OS Mem 
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Project > Compile or clicking on th

Compiling the project checks for any syntax errors in your program, you should not encounter any errors here.  

from the bottom indication in Bco

t, let’s download it into the BCore. From the 

icon on the tool bar.  

You may have to wait for a moment for the download process to complete. Your download is successful if 

Make sure your power supply is on.  The power indicator on your BCore

Key is connected properly to the BCore board and to your PC.

ult, programs downloaded are stored in the Core’s SRAM. This memory is volatile, meaning that if you 

power off the board and power it up again, your program will be gone.  

Once you are ready and you have finalized your program, you may save the program in

DataFlash chip. On power up, the Core will take the program from the DataFlash chip, transfer it into its 

To save your program into the DataFlash Chip, you need to perform the following 2 steps.

Release 

or clicking on the Compile Icon on the 

Compiling the project checks for any syntax errors in your program, you should not encounter any errors here.  

from the bottom indication in Bcore

. From the BCoreIDE

You may have to wait for a moment for the download process to complete. Your download is successful if 

BCore board should light up.

board and to your PC.

ult, programs downloaded are stored in the Core’s SRAM. This memory is volatile, meaning that if you 

Once you are ready and you have finalized your program, you may save the program into the onboard 

DataFlash chip. On power up, the Core will take the program from the DataFlash chip, transfer it into its 

To save your program into the DataFlash Chip, you need to perform the following 2 steps.

Compile Icon on the 

Compiling the project checks for any syntax errors in your program, you should not encounter any errors here.  

reIDE. For now, you 

BCoreIDE menu choose: 

You may have to wait for a moment for the download process to complete. Your download is successful if 

board should light up. 

board and to your PC. 

ult, programs downloaded are stored in the Core’s SRAM. This memory is volatile, meaning that if you 

to the onboard 

DataFlash chip. On power up, the Core will take the program from the DataFlash chip, transfer it into its 

To save your program into the DataFlash Chip, you need to perform the following 2 steps. 

Compile Icon on the 

Compiling the project checks for any syntax errors in your program, you should not encounter any errors here.  

IDE. For now, you 

menu choose: 

You may have to wait for a moment for the download process to complete. Your download is successful if 

ult, programs downloaded are stored in the Core’s SRAM. This memory is volatile, meaning that if you 

to the onboard 

DataFlash chip. On power up, the Core will take the program from the DataFlash chip, transfer it into its 

    



 

The Hello World Program
Congratulations, you have successfully created, compiled and downloaded your first FI Project. 

Now for more VB coding.

 

The language you will be using 

you work more with 

when programming on the

 

Debug.Print

the Serial Download Port

 

Now Download and Compile your project. 

(Reminder

 

Understanding the Hello World Program
 

A Project consists of one or more modules.  Each Module consists of a declaration and one or more 

Subroutine.  Every Project must have the Main() subroutine.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Hello World!

Project Name 

Between the Public Sub Main() and the End Sub is where you write your program.

 

In our Project

The first line ‘Module01 is a commented line which means that t

commented line is 

 

The Hello World Program
Congratulations, you have successfully created, compiled and downloaded your first FI Project. 

Now for more VB coding.

anguage you will be using 

you work more with BCoreIDE

when programming on the

Debug.Print is a BCore OS 

the Serial Download Port

Now Download and Compile your project. 

Reminder: you can Download and Compile your project by pressing F5 or clicking the 

Understanding the Hello World Program

A Project consists of one or more modules.  Each Module consists of a declaration and one or more 

Subroutine.  Every Project must have the Main() subroutine.

Hello World!

Project Name 

MODULE

Project Name : Module01

Public Sub Main()

Subroutines

Public Sub Foo()

Declaration

Between the Public Sub Main() and the End Sub is where you write your program.

In our Project, we have 1 Module and 1 Subroutine call

The first line ‘Module01 is a commented line which means that t

commented line is denoted by its highlighted colour (BCore 

The Hello World Program 
Congratulations, you have successfully created, compiled and downloaded your first FI Project. 

Now for more VB coding. 

anguage you will be using is VB.NET

BCoreIDE. One of which is that the language is streamlined to 

when programming on the .NET platform and style instead of the convent

BCore OS command that sends the 

the Serial Download Port.  In this case it sends “HELLO WORLD” to the PC.  

Now Download and Compile your project. 

: you can Download and Compile your project by pressing F5 or clicking the 

 

After Compiling and Downloading your Project, you should see the message “HELLO 

WORLD” appearing at the debug window. The debug window is located to the right 

of your editor.

 

Understanding the Hello World Program

A Project consists of one or more modules.  Each Module consists of a declaration and one or more 

Subroutine.  Every Project must have the Main() subroutine.

Hello World! 

PROJECT

Project Name : Project01

Project Name 

()

()

Between the Public Sub Main() and the End Sub is where you write your program.

, we have 1 Module and 1 Subroutine call

The first line ‘Module01 is a commented line which means that t

denoted by its highlighted colour (BCore Getting started rev.b

Congratulations, you have successfully created, compiled and downloaded your first FI Project. 

is VB.NET (Visual Basic); there are a number of differences as you will see when 

. One of which is that the language is streamlined to 

.NET platform and style instead of the convent

 

In the 

 Debug.Print

 

 

 

Note: 

automatically format your text as you type.

 

 

command that sends the 

.  In this case it sends “HELLO WORLD” to the PC.  

Now Download and Compile your project.  

: you can Download and Compile your project by pressing F5 or clicking the 

After Compiling and Downloading your Project, you should see the message “HELLO 

WORLD” appearing at the debug window. The debug window is located to the right 

of your editor. 

Understanding the Hello World Program

A Project consists of one or more modules.  Each Module consists of a declaration and one or more 

Subroutine.  Every Project must have the Main() subroutine.

 

MODULE

Project Name : Module02

Between the Public Sub Main() and the End Sub is where you write your program.

, we have 1 Module and 1 Subroutine call

The first line ‘Module01 is a commented line which means that t

denoted by its highlighted colour (Getting started rev.b | 

Congratulations, you have successfully created, compiled and downloaded your first FI Project. 

(Visual Basic); there are a number of differences as you will see when 

. One of which is that the language is streamlined to 

.NET platform and style instead of the convent

In the BCoreIDE Editor, 

Debug.Print “HELLO WORLD”

 It is best to leave your Caps Lock 

automatically format your text as you type.

command that sends the message between the quotes back to the PC

.  In this case it sends “HELLO WORLD” to the PC.  

: you can Download and Compile your project by pressing F5 or clicking the 

After Compiling and Downloading your Project, you should see the message “HELLO 

WORLD” appearing at the debug window. The debug window is located to the right 

Understanding the Hello World Program 

A Project consists of one or more modules.  Each Module consists of a declaration and one or more 

Subroutine.  Every Project must have the Main() subroutine. 

02

Between the Public Sub Main() and the End Sub is where you write your program.

, we have 1 Module and 1 Subroutine called Sub Main().  There are no declarations in our Project.  

The first line ‘Module01 is a commented line which means that t

denoted by its highlighted colour (green). | APRIL 2011 Release

Congratulations, you have successfully created, compiled and downloaded your first FI Project. 

(Visual Basic); there are a number of differences as you will see when 

. One of which is that the language is streamlined to 

.NET platform and style instead of the conventional VB language.

Editor, type the following;

“HELLO WORLD”

It is best to leave your Caps Lock 

automatically format your text as you type.

message between the quotes back to the PC

.  In this case it sends “HELLO WORLD” to the PC.   

: you can Download and Compile your project by pressing F5 or clicking the 

After Compiling and Downloading your Project, you should see the message “HELLO 

WORLD” appearing at the debug window. The debug window is located to the right 

A Project consists of one or more modules.  Each Module consists of a declaration and one or more 

Between the Public Sub Main() and the End Sub is where you write your program.

Main().  There are no declarations in our Project.  

The first line ‘Module01 is a commented line which means that the compiler does not execute the line.  A 
Release 

Congratulations, you have successfully created, compiled and downloaded your first FI Project. 

(Visual Basic); there are a number of differences as you will see when 

. One of which is that the language is streamlined to be similar to that used 

ional VB language.

type the following; 

“HELLO WORLD” 

It is best to leave your Caps Lock ON.  The Editor will 

automatically format your text as you type. 

message between the quotes back to the PC

 

: you can Download and Compile your project by pressing F5 or clicking the 

After Compiling and Downloading your Project, you should see the message “HELLO 

WORLD” appearing at the debug window. The debug window is located to the right 

A Project consists of one or more modules.  Each Module consists of a declaration and one or more 

Between the Public Sub Main() and the End Sub is where you write your program. 

Main().  There are no declarations in our Project.  

he compiler does not execute the line.  A 

Congratulations, you have successfully created, compiled and downloaded your first FI Project.  

(Visual Basic); there are a number of differences as you will see when 

be similar to that used 

ional VB language. 

.  The Editor will 

message between the quotes back to the PC through 

icon.) 

After Compiling and Downloading your Project, you should see the message “HELLO 

WORLD” appearing at the debug window. The debug window is located to the right 

A Project consists of one or more modules.  Each Module consists of a declaration and one or more 

Main().  There are no declarations in our Project.  

he compiler does not execute the line.  A 

(Visual Basic); there are a number of differences as you will see when 

be similar to that used 

.  The Editor will 

through 

After Compiling and Downloading your Project, you should see the message “HELLO 

WORLD” appearing at the debug window. The debug window is located to the right 

Main().  There are no declarations in our Project.  

he compiler does not execute the line.  A 
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The BLINKY LED Program 
Here’s another simple program. If you have an LED module, you can turn on and turn off the LED by using the 

following OS commands. 

HIGH 
Set logic 1 at the specified pin.  

 

HIGH [ pin no. ] 

 

LOW 
Set logic 0 at the specified pin.  

 

LOW [ pin no. ] 

 

NOTE: I/O pins are tied low to the ground on the hardware therefore explaining the inverse result as opposed 

to the logic statements. 

 

Write the following program and when you’re done, Compile and Download it. 

 

 
 

Replace ‘x’ with the pin number assigned to the IO pins on the BCore Board to which you connected the LED. 

You can obtain these numbers by referring to the BCore Reference Documentation (Hardware) for your 

respective BCore Board. 

 

Hint: You can restart the program by pressing the master reset button on the BCore board. 

 

After downloading the program, you will find that the LED blinks once for 200 msec. 

 

Understanding the Blinky led Program 
The Program starts by sending “HELLO WORLD” to the PC.  Then the LED will be turned on.  The program waits 

for 200 msec (or 0.2 sec) before turning the green LED off. And that’s it! 

 

 

 

  

 

BLINKY LEDs!! 
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Basic structure: Do… Loop 

In the previous program, we will need to type 3 times to blink the green LED 3 times.  Or maybe we can just 

cut and paste the 3 lines.  What do we need for the BCore to instruct the LED to blink indefinitely? 

What we need is to implement is a structure called Do…Loop. 

 

Type in the following program and read the explanation before downloading it. 

 

 

The Do Loop repeats all commands between the Do and the Loop. 

Note the Delay(200) Command After the High Command. This is required before it executes the next 

instruction, which is Low(x), not having a delay would result in the LEDs turning on and off so fast so fast, 

(Remember, the BCore is able to execute instructions at up to 5 Million lines of instructions per second), that 

the human eye will not be able to see the LED Blinking. 

  

 

BLINKY LEDs!! (Cont’d) 
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Notes 

    

Latest documentation 

All of our documentations are constantly updated to provide accurate and/or new information that we feel 

would help you with developing with our products.  

 

The latest documentation may be obtained from our website: http://www.aiscube.com/main/downloads.html 

 

How you can help 

You can help us to improve our documentations by emailing to us or posting a thread in our forum, reporting 

any mistakes/typos or errata that you might spot while reading our documentation.  

 

Email: TechSupport@aiscube.com 

Disclaimer 

All information in this documentation is provided ‘as-is’ without any warranty of any kind. 

 

The products produced by AIS Cube are meant for rapid prototyping and experimental usage; they are not 

intended nor designed for implementation in environments that constitute high risk activities. 

AIS Cube shall assume no responsibility or liability for any indirect, specific, incidental or consequential 

damages arising out of the use of this documentation or product.  

 

Copyright 2009 - 2011 AIS Cube. All rights reserved. 

All product and corporate names appearing in this documentation may or may not be registered trademarks or 

copyrights of their respective companies, and are only used for identification or explanation for the owner’s benefit, 

with no intent to infringe. 

BCore ide and BlazingCore(BCore) are trademarks of AIS Cube in Singapore and/or other countries. All images depicting 

the Blazingcore or any part of it is copyrighted. 

All other trademarks or registered trademarks are the property of their respective owners. 


